Unverified Commit 83b48932 authored by csett86's avatar csett86 Committed by GitHub
Browse files

chore(deps): update electron-builder to 22.11.11 and move to node 14(#583)



electron-builder 22.11.0+ requires node 14, so update node 12 -> node 14
as well.
Signed-off-by: default avatarChristoph Settgast <csett86@web.de>
parent 8544d2c3
......@@ -20,7 +20,7 @@ jobs:
- uses: actions/checkout@v2
- uses: actions/setup-node@v1
with:
node-version: '12.x'
node-version: '14.x'
- name: Install dependencies
run: sudo apt-get install libx11-dev zlib1g-dev libpng-dev libxtst-dev
- name: Build it
......@@ -36,7 +36,7 @@ jobs:
- uses: actions/checkout@v2
- uses: actions/setup-node@v1
with:
node-version: '12.x'
node-version: '14.x'
- name: Fixup Xcode
# https://github.com/actions/virtual-environments/issues/2557
run: |
......@@ -56,7 +56,7 @@ jobs:
- uses: actions/checkout@v2
- uses: actions/setup-node@v1
with:
node-version: '12.x'
node-version: '14.x'
- name: Build it
env:
GH_TOKEN: ${{ secrets.GITHUB_TOKEN }}
......
12
\ No newline at end of file
14
......@@ -58,7 +58,7 @@ If you want to hack on this project, here is how you do it.
#### Installing dependencies
Install Node.js 12 first (or if you use [nvm](https://github.com/nvm-sh/nvm), switch to Node.js 12 by running `nvm use`).
Install Node.js 14 first (or if you use [nvm](https://github.com/nvm-sh/nvm), switch to Node.js 14 by running `nvm use`).
<details><summary>Extra dependencies for Windows</summary>
......
This diff is collapsed.
......@@ -14,7 +14,7 @@
"watch": "webpack --config ./webpack.renderer.js --mode development --watch --watch-poll"
},
"engines": {
"node": ">=12.0.0"
"node": ">=14.0.0"
},
"build": {
"appId": "org.jitsi.jitsi-meet",
......@@ -156,13 +156,13 @@
"concurrently": "5.1.0",
"css-loader": "3.5.0",
"electron": "13.4.0",
"electron-builder": "22.10.5",
"electron-builder": "22.11.11",
"electron-context-menu": "^2.5.0",
"electron-is-dev": "^1.2.0",
"electron-log": "^4.3.2",
"electron-react-devtools": "0.5.3",
"electron-store": "^5.2.0",
"electron-updater": "^4.3.8",
"electron-updater": "^4.4.3",
"electron-window-state": "^5.0.3",
"eslint": "6.5.1",
"eslint-config-jitsi": "github:jitsi/eslint-config-jitsi#1.0.2",
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment